summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qprocessenvironment/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qprocessenvironment/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qprocessenvironment/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/tests/auto/corelib/io/qprocessenvironment/CMakeLists.txt b/tests/auto/corelib/io/qprocessenvironment/CMakeLists.txt
index d612a32374..02c6909031 100644
--- a/tests/auto/corelib/io/qprocessenvironment/CMakeLists.txt
+++ b/tests/auto/corelib/io/qprocessenvironment/CMakeLists.txt
@@ -1,10 +1,19 @@
-# Generated from qprocessenvironment.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qprocessenvironment Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qprocessenvironment LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qprocessenvironment
SOURCES
tst_qprocessenvironment.cpp
+ LIBRARIES
+ Qt::TestPrivate
)