summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qstandardpaths/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qstandardpaths/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qstandardpaths/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/qstandardpaths/CMakeLists.txt b/tests/auto/corelib/io/qstandardpaths/CMakeLists.txt
new file mode 100644
index 0000000000..5bceaf1d77
--- /dev/null
+++ b/tests/auto/corelib/io/qstandardpaths/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Generated from qstandardpaths.pro.
+
+#####################################################################
+## tst_qstandardpaths Test:
+#####################################################################
+
+# Collect test data
+list(APPEND test_data "tst_qstandardpaths.cpp")
+list(APPEND test_data "qstandardpaths.pro")
+
+add_qt_test(tst_qstandardpaths
+ SOURCES
+ ../../../../shared/emulationdetector.h
+ tst_qstandardpaths.cpp
+ INCLUDE_DIRECTORIES
+ ../../../../shared
+ TESTDATA ${test_data}
+)
+
+## Scopes:
+#####################################################################
+
+extend_target(tst_qstandardpaths CONDITION boot2qt
+ DEFINES
+ SKIP_FINDEXECUTABLE
+)