summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt26
1 files changed, 17 insertions, 9 deletions
diff --git a/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt b/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
index b1c324ca17..693e2c674c 100644
--- a/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
+++ b/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
@@ -8,7 +8,6 @@
list(APPEND test_data "tst_qtemporaryfile.cpp")
add_qt_test(tst_qtemporaryfile
- GUI
SOURCES
tst_qtemporaryfile.cpp
LIBRARIES
@@ -17,23 +16,32 @@ add_qt_test(tst_qtemporaryfile
)
# Resources:
+set(qtemporaryfile_resource_files
+ "resources/test.txt"
+)
+
add_qt_resource(tst_qtemporaryfile "qtemporaryfile"
PREFIX
"/"
FILES
- "resources/test.txt"
+ ${qtemporaryfile_resource_files}
)
## Scopes:
#####################################################################
-# Resources:
-add_qt_resource(tst_qtemporaryfile "android_testdata"
- PREFIX
- "/android_testdata"
- FILES
+if(ANDROID AND NOT ANDROID_EMBEDDED)
+ # Resources:
+ set(android_testdata_resource_files
"resources/test.txt"
"tst_qtemporaryfile.cpp"
-)
-
+ )
+
+ add_qt_resource(tst_qtemporaryfile "android_testdata"
+ PREFIX
+ "/android_testdata"
+ FILES
+ ${android_testdata_resource_files}
+ )
+endif()