summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt28
1 files changed, 18 insertions, 10 deletions
diff --git a/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt b/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
index b1c324ca17..af614552cc 100644
--- a/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
+++ b/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
@@ -8,32 +8,40 @@
list(APPEND test_data "tst_qtemporaryfile.cpp")
add_qt_test(tst_qtemporaryfile
- GUI
SOURCES
tst_qtemporaryfile.cpp
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::TestPrivate
TESTDATA ${test_data}
)
# Resources:
+set(qtemporaryfile_resource_files
+ "resources/test.txt"
+)
+
add_qt_resource(tst_qtemporaryfile "qtemporaryfile"
PREFIX
"/"
FILES
- "resources/test.txt"
+ ${qtemporaryfile_resource_files}
)
## Scopes:
#####################################################################
-# Resources:
-add_qt_resource(tst_qtemporaryfile "android_testdata"
- PREFIX
- "/android_testdata"
- FILES
+if(ANDROID AND NOT ANDROID_EMBEDDED)
+ # Resources:
+ set(android_testdata_resource_files
"resources/test.txt"
"tst_qtemporaryfile.cpp"
-)
-
+ )
+
+ add_qt_resource(tst_qtemporaryfile "android_testdata"
+ PREFIX
+ "/android_testdata"
+ FILES
+ ${android_testdata_resource_files}
+ )
+endif()