summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt27
1 files changed, 18 insertions, 9 deletions
diff --git a/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt b/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
index 7acf70fd36..b1c324ca17 100644
--- a/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
+++ b/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
@@ -4,27 +4,36 @@
## tst_qtemporaryfile Test:
#####################################################################
+# Collect test data
+list(APPEND test_data "tst_qtemporaryfile.cpp")
+
add_qt_test(tst_qtemporaryfile
+ GUI
SOURCES
tst_qtemporaryfile.cpp
LIBRARIES
Qt::TestPrivate
+ TESTDATA ${test_data}
)
# Resources:
-add_qt_resource(tst_qtemporaryfile "qtemporaryfile" FILES
- resources/test.txt)
-
+add_qt_resource(tst_qtemporaryfile "qtemporaryfile"
+ PREFIX
+ "/"
+ FILES
+ "resources/test.txt"
+)
-#### Keys ignored in scope 1:.:.:qtemporaryfile.pro:<TRUE>:
-# CONFIG = "testcase"
-# TESTDATA = "tst_qtemporaryfile.cpp"
## Scopes:
#####################################################################
# Resources:
-add_qt_resource(tst_qtemporaryfile "android_testdata" PREFIX "/android_testdata" FILES
- resources/test.txt
- tst_qtemporaryfile.cpp)
+add_qt_resource(tst_qtemporaryfile "android_testdata"
+ PREFIX
+ "/android_testdata"
+ FILES
+ "resources/test.txt"
+ "tst_qtemporaryfile.cpp"
+)