summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt b/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
new file mode 100644
index 0000000000..b1c324ca17
--- /dev/null
+++ b/tests/auto/corelib/io/qtemporaryfile/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Generated from qtemporaryfile.pro.
+
+#####################################################################
+## tst_qtemporaryfile Test:
+#####################################################################
+
+# Collect test data
+list(APPEND test_data "tst_qtemporaryfile.cpp")
+
+add_qt_test(tst_qtemporaryfile
+ GUI
+ SOURCES
+ tst_qtemporaryfile.cpp
+ LIBRARIES
+ Qt::TestPrivate
+ TESTDATA ${test_data}
+)
+
+# Resources:
+add_qt_resource(tst_qtemporaryfile "qtemporaryfile"
+ PREFIX
+ "/"
+ FILES
+ "resources/test.txt"
+)
+
+
+## Scopes:
+#####################################################################
+
+# Resources:
+add_qt_resource(tst_qtemporaryfile "android_testdata"
+ PREFIX
+ "/android_testdata"
+ FILES
+ "resources/test.txt"
+ "tst_qtemporaryfile.cpp"
+)
+