summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qurl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qurl/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qurl/CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/tests/auto/corelib/io/qurl/CMakeLists.txt b/tests/auto/corelib/io/qurl/CMakeLists.txt
index 2ea06f62d7..d105b323df 100644
--- a/tests/auto/corelib/io/qurl/CMakeLists.txt
+++ b/tests/auto/corelib/io/qurl/CMakeLists.txt
@@ -1,20 +1,28 @@
-# Generated from qurl.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qurl Test:
#####################################################################
-qt_add_test(tst_qurl
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qurl LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qurl
SOURCES
tst_qurl.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Concurrent
+ Qt::TestPrivate
)
## Scopes:
#####################################################################
-qt_extend_target(tst_qurl CONDITION APPLE
+qt_internal_extend_target(tst_qurl CONDITION APPLE
SOURCES
tst_qurl_mac.mm
)