summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qurlinternal/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qurlinternal/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qurlinternal/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/auto/corelib/io/qurlinternal/CMakeLists.txt b/tests/auto/corelib/io/qurlinternal/CMakeLists.txt
index 21e661a17f..c941d6811c 100644
--- a/tests/auto/corelib/io/qurlinternal/CMakeLists.txt
+++ b/tests/auto/corelib/io/qurlinternal/CMakeLists.txt
@@ -1,14 +1,20 @@
# Generated from qurlinternal.pro.
+if(NOT QT_FEATURE_private_tests)
+ return()
+endif()
+
#####################################################################
## tst_qurlinternal Test:
#####################################################################
add_qt_test(tst_qurlinternal
- GUI
SOURCES
../../codecs/utf8/utf8data.cpp
tst_qurlinternal.cpp
LIBRARIES
Qt::CorePrivate
)
+
+#### Keys ignored in scope 1:.:.:qurlinternal.pro:<TRUE>:
+# _REQUIREMENTS = "qtConfig(private_tests)"