summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qurluts46/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qurluts46/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qurluts46/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/qurluts46/CMakeLists.txt b/tests/auto/corelib/io/qurluts46/CMakeLists.txt
new file mode 100644
index 0000000000..ac3f7cac48
--- /dev/null
+++ b/tests/auto/corelib/io/qurluts46/CMakeLists.txt
@@ -0,0 +1,19 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qurluts46 Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qurluts46 LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qurluts46
+ SOURCES
+ tst_qurluts46.cpp
+ TESTDATA
+ testdata/IdnaTestV2.txt
+)