summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/kernel/qeventloop/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/kernel/qeventloop/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/kernel/qeventloop/CMakeLists.txt19
1 files changed, 13 insertions, 6 deletions
diff --git a/tests/auto/corelib/kernel/qeventloop/CMakeLists.txt b/tests/auto/corelib/kernel/qeventloop/CMakeLists.txt
index b09f6715e1..5d90f97b21 100644
--- a/tests/auto/corelib/kernel/qeventloop/CMakeLists.txt
+++ b/tests/auto/corelib/kernel/qeventloop/CMakeLists.txt
@@ -1,13 +1,20 @@
-# Generated from qeventloop.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qeventloop Test:
#####################################################################
-qt_add_test(tst_qeventloop
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qeventloop LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qeventloop
SOURCES
tst_qeventloop.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::Network
)
@@ -15,12 +22,12 @@ qt_add_test(tst_qeventloop
## Scopes:
#####################################################################
-qt_extend_target(tst_qeventloop CONDITION WIN32
- PUBLIC_LIBRARIES
+qt_internal_extend_target(tst_qeventloop CONDITION WIN32
+ LIBRARIES
user32
)
-qt_extend_target(tst_qeventloop CONDITION QT_FEATURE_glib
+qt_internal_extend_target(tst_qeventloop CONDITION QT_FEATURE_glib
DEFINES
HAVE_GLIB
)