summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/plugin/qplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/plugin/qplugin/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/plugin/qplugin/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/auto/corelib/plugin/qplugin/CMakeLists.txt b/tests/auto/corelib/plugin/qplugin/CMakeLists.txt
new file mode 100644
index 0000000000..b2829099aa
--- /dev/null
+++ b/tests/auto/corelib/plugin/qplugin/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Generated from qplugin.pro.
+
+add_subdirectory(invalidplugin)
+
+# special case begin
+add_subdirectory(debugplugin)
+add_subdirectory(releaseplugin)
+
+# The contents below are generated from ./tst_qplugin.pro
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ plugins/*)
+list(APPEND test_data ${test_data_glob})
+
+add_qt_test(tst_qplugin
+ SOURCES
+ tst_qplugin.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ TESTDATA ${test_data}
+)
+
+target_compile_definitions(tst_qplugin PRIVATE CMAKE_BUILD=1)
+
+add_dependencies(tst_qplugin invalidplugin debugplugin releaseplugin)
+# special case end