summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt32
1 files changed, 21 insertions, 11 deletions
diff --git a/tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt b/tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt
index 5a8bf518c5..dfce9d6a52 100644
--- a/tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt
+++ b/tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt
@@ -1,8 +1,5 @@
-# Generated from theplugin.pro.
-
-#####################################################################
-## theplugin Generic Library:
-#####################################################################
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
qt_internal_add_cmake_library(theplugin
MODULE
@@ -10,13 +7,26 @@ qt_internal_add_cmake_library(theplugin
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../bin"
SOURCES
theplugin.cpp theplugin.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Core
)
+qt_autogen_tools_initial_setup(theplugin)
-#### Keys ignored in scope 1:.:.:theplugin.pro:<TRUE>:
-# INSTALLS = "target"
-# TEMPLATE = "lib"
-# target.path = "$$[QT_INSTALL_TESTS]/tst_qpluginloader/bin"
+if (UNIX AND NOT APPLE)
+ qt_internal_add_cmake_library(theoldplugin
+ MODULE
+ INSTALL_DIRECTORY "${INSTALL_TESTSDIR}/tst_qpluginloader/bin"
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../bin"
+ SOURCES
+ theoldplugin.cpp theoldplugin.h
+ LIBRARIES
+ Qt::Core
+ )
+ qt_autogen_tools_initial_setup(theoldplugin)
+
+ # Force unoptimized builds with debugging information so some "QTMETADATA !"
+ # strings appear elsewhere in the binary.
+ target_compile_options(theplugin PRIVATE -O0 -g3)
+ target_compile_options(theoldplugin PRIVATE -O0 -g3)
+endif()
-qt_autogen_tools_initial_setup(theplugin)