summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/plugin/quuid/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/plugin/quuid/test/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/plugin/quuid/test/CMakeLists.txt24
1 files changed, 10 insertions, 14 deletions
diff --git a/tests/auto/corelib/plugin/quuid/test/CMakeLists.txt b/tests/auto/corelib/plugin/quuid/test/CMakeLists.txt
index 1ba9de95ca..1e1e820b14 100644
--- a/tests/auto/corelib/plugin/quuid/test/CMakeLists.txt
+++ b/tests/auto/corelib/plugin/quuid/test/CMakeLists.txt
@@ -1,30 +1,26 @@
-# Generated from test.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_quuid Test:
#####################################################################
-qt_add_test(tst_quuid
- OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../" # special case
+qt_internal_add_test(tst_quuid
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../"
SOURCES
../tst_quuid.cpp
)
## Scopes:
-#####################################################################
-qt_extend_target(tst_quuid CONDITION APPLE
+qt_internal_extend_target(tst_quuid CONDITION APPLE
SOURCES
../tst_quuid_darwin.mm
- PUBLIC_LIBRARIES
+ LIBRARIES
+ Qt::CorePrivate
${FWFoundation}
)
-#### Keys ignored in scope 4:.:.:test.pro:(CMAKE_BUILD_TYPE STREQUAL Debug):
-# DESTDIR = "../debug"
-
-#### Keys ignored in scope 5:.:.:test.pro:else:
-# DESTDIR = "../release"
-
-#### Keys ignored in scope 6:.:.:test.pro:else:
-# DESTDIR = ".."
+if(QT_FEATURE_process AND NOT ANDROID)
+ add_dependencies(tst_quuid testProcessUniqueness)
+endif()