summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/serialization/json/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/serialization/json/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/serialization/json/CMakeLists.txt49
1 files changed, 21 insertions, 28 deletions
diff --git a/tests/auto/corelib/serialization/json/CMakeLists.txt b/tests/auto/corelib/serialization/json/CMakeLists.txt
index 9022ed9f3d..c73a99a3b8 100644
--- a/tests/auto/corelib/serialization/json/CMakeLists.txt
+++ b/tests/auto/corelib/serialization/json/CMakeLists.txt
@@ -1,42 +1,35 @@
-# Generated from json.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_json Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_json LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+set(json_resource_files
+ "bom.json"
+ "test.json"
+ "test2.json"
+ "test3.json"
+ "simple.duplicates.json"
+ "test.duplicates.json"
+ "test3.duplicates.json"
+)
+
qt_internal_add_test(tst_json
SOURCES
tst_qtjson.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
+ Qt::TestPrivate
+ TESTDATA ${json_resource_files}
)
-## Scopes:
-#####################################################################
-
-#### Keys ignored in scope 2:.:.:json.pro:NOT ANDROID:
-# TESTDATA = "bom.json" "test.json" "test3.json" "test2.json"
-
-if(ANDROID OR INTEGRITY)
- # Resources:
- set(json_resource_files
- "bom.json"
- "test.json"
- "test2.json"
- "test3.json"
- "simple.duplicates.json"
- "test.duplicates.json"
- "test3.duplicates.json"
- )
-
- qt_internal_add_resource(tst_json "json"
- PREFIX
- "/"
- FILES
- ${json_resource_files}
- )
-endif()
-
qt_internal_extend_target(tst_json CONDITION NOT QT_FEATURE_doubleconversion AND NOT QT_FEATURE_system_doubleconversion
DEFINES
QT_NO_DOUBLECONVERSION