summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/serialization/json/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/serialization/json/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/serialization/json/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/tests/auto/corelib/serialization/json/CMakeLists.txt b/tests/auto/corelib/serialization/json/CMakeLists.txt
index 01432873f5..c73a99a3b8 100644
--- a/tests/auto/corelib/serialization/json/CMakeLists.txt
+++ b/tests/auto/corelib/serialization/json/CMakeLists.txt
@@ -1,9 +1,16 @@
-# Generated from json.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_json Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_json LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
set(json_resource_files
"bom.json"
"test.json"
@@ -17,8 +24,9 @@ set(json_resource_files
qt_internal_add_test(tst_json
SOURCES
tst_qtjson.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
+ Qt::TestPrivate
TESTDATA ${json_resource_files}
)