summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt34
1 files changed, 10 insertions, 24 deletions
diff --git a/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt b/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
index cb48aed16c..588a49fcf0 100644
--- a/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
+++ b/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
#####################################################################
## tst_qtextstream Test:
#####################################################################
@@ -15,12 +18,17 @@ qt_internal_add_test(tst_qtextstream
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../"
SOURCES
../tst_qtextstream.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Network
Qt::TestPrivate
TESTDATA ${test_data}
+ QT_TEST_SERVER_LIST "cyrus"
)
+if(QT_FEATURE_sanitize_address)
+ set_property(TEST tst_qtextstream APPEND PROPERTY ENVIRONMENT "QTEST_FUNCTION_TIMEOUT=900000")
+endif()
+
# Resources:
set(qtextstream_resource_files
"../resources/big_endian/"
@@ -36,28 +44,6 @@ qt_internal_add_resource(tst_qtextstream "qtextstream"
${qtextstream_resource_files}
)
-if(INTEGRITY)
-set(qtextstream_resource_files_integrity
- "../rfc3261.txt"
- "../task113817.txt"
- "../tst_qtextstream.cpp"
-)
-
-qt_internal_add_resource(tst_qtextstream "qtextstream_integrity"
- PREFIX
- "/"
- FILES
- ${qtextstream_resource_files_integrity}
-)
-endif()
-
-## Scopes:
-
-qt_internal_extend_target(tst_qtextstream CONDITION builtin_testdata OR INTEGRITY
- DEFINES
- BUILTIN_TESTDATA
-)
-
if(QT_FEATURE_process)
- add_dependencies(tst_qtextstream stdinProcess readAllStdinProcess readLineStdinProcess)
+ add_dependencies(tst_qtextstream stdinProcess readAllStdinProcess readLineStdinProcess)
endif()