summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/text/qchar/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/text/qchar/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/text/qchar/CMakeLists.txt28
1 files changed, 9 insertions, 19 deletions
diff --git a/tests/auto/corelib/text/qchar/CMakeLists.txt b/tests/auto/corelib/text/qchar/CMakeLists.txt
index 06faffb60e..03b99356ea 100644
--- a/tests/auto/corelib/text/qchar/CMakeLists.txt
+++ b/tests/auto/corelib/text/qchar/CMakeLists.txt
@@ -1,33 +1,23 @@
-# Generated from qchar.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qchar Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qchar LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
# Collect test data
list(APPEND test_data "data/NormalizationTest.txt")
qt_internal_add_test(tst_qchar
SOURCES
tst_qchar.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
TESTDATA ${test_data}
)
-
-## Scopes:
-#####################################################################
-
-if(ANDROID OR INTEGRITY)
- # Resources:
- set(testdata_resource_files
- "data/NormalizationTest.txt"
- )
-
- qt_internal_add_resource(tst_qchar "testdata"
- PREFIX
- "/"
- FILES
- ${testdata_resource_files}
- )
-endif()