summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/text/qunicodetools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/text/qunicodetools/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/text/qunicodetools/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/auto/corelib/text/qunicodetools/CMakeLists.txt b/tests/auto/corelib/text/qunicodetools/CMakeLists.txt
new file mode 100644
index 0000000000..fe7d8e35e2
--- /dev/null
+++ b/tests/auto/corelib/text/qunicodetools/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qunicodetools Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qunicodetools LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qunicodetools
+ SOURCES
+ tst_qunicodetools.cpp
+ LIBRARIES
+ Qt::CorePrivate
+)
+