summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/thread/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/thread/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/thread/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/auto/corelib/thread/CMakeLists.txt b/tests/auto/corelib/thread/CMakeLists.txt
index b73d9af059..8c3e33d6dc 100644
--- a/tests/auto/corelib/thread/CMakeLists.txt
+++ b/tests/auto/corelib/thread/CMakeLists.txt
@@ -12,7 +12,12 @@ if(QT_FEATURE_thread)
add_subdirectory(qreadlocker)
add_subdirectory(qreadwritelock)
add_subdirectory(qsemaphore)
- add_subdirectory(qthread)
+ # special case begin
+ # QTBUG-85364
+ if(NOT CMAKE_CROSSCOMPILING)
+ add_subdirectory(qthread)
+ endif()
+ # special case end
add_subdirectory(qthreadonce)
add_subdirectory(qthreadpool)
add_subdirectory(qthreadstorage)