summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/thread/qfuture/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/thread/qfuture/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/thread/qfuture/CMakeLists.txt20
1 files changed, 16 insertions, 4 deletions
diff --git a/tests/auto/corelib/thread/qfuture/CMakeLists.txt b/tests/auto/corelib/thread/qfuture/CMakeLists.txt
index dcf7846fd2..aa989f3df1 100644
--- a/tests/auto/corelib/thread/qfuture/CMakeLists.txt
+++ b/tests/auto/corelib/thread/qfuture/CMakeLists.txt
@@ -1,14 +1,26 @@
-# Generated from qfuture.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qfuture Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qfuture LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qfuture
SOURCES
tst_qfuture.cpp
-# DEFINES
-# -QT_NO_JAVA_STYLE_ITERATORS
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
)
+
+qt_internal_extend_target(tst_qfuture CONDITION MSVC
+ COMPILE_OPTIONS
+ /bigobj
+)
+
+qt_internal_undefine_global_definition(tst_qfuture QT_NO_JAVA_STYLE_ITERATORS)