summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/thread/qmutex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/thread/qmutex/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/thread/qmutex/CMakeLists.txt17
1 files changed, 9 insertions, 8 deletions
diff --git a/tests/auto/corelib/thread/qmutex/CMakeLists.txt b/tests/auto/corelib/thread/qmutex/CMakeLists.txt
index 41b7b1da68..5a92a2bffd 100644
--- a/tests/auto/corelib/thread/qmutex/CMakeLists.txt
+++ b/tests/auto/corelib/thread/qmutex/CMakeLists.txt
@@ -1,18 +1,19 @@
-# Generated from qmutex.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qmutex Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qmutex LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qmutex
SOURCES
tst_qmutex.cpp
-)
-
-## Scopes:
-#####################################################################
-
-qt_internal_extend_target(tst_qmutex CONDITION WIN32
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
)