summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/thread/qthread/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/thread/qthread/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/thread/qthread/CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/tests/auto/corelib/thread/qthread/CMakeLists.txt b/tests/auto/corelib/thread/qthread/CMakeLists.txt
index b3662f31da..abcea1ef9c 100644
--- a/tests/auto/corelib/thread/qthread/CMakeLists.txt
+++ b/tests/auto/corelib/thread/qthread/CMakeLists.txt
@@ -1,15 +1,21 @@
-# Generated from qthread.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qthread Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qthread LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qthread
SOURCES
- ../../../../shared/emulationdetector.h
tst_qthread.cpp
- INCLUDE_DIRECTORIES
- ../../../../shared
+ LIBRARIES
+ Qt::TestPrivate
)
## Scopes: