summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/tools/qsharedpointer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/tools/qsharedpointer/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/tools/qsharedpointer/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/auto/corelib/tools/qsharedpointer/CMakeLists.txt b/tests/auto/corelib/tools/qsharedpointer/CMakeLists.txt
new file mode 100644
index 0000000000..0db0cba4c0
--- /dev/null
+++ b/tests/auto/corelib/tools/qsharedpointer/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qsharedpointer Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qsharedpointer LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qsharedpointer
+ SOURCES
+ forwarddeclared.cpp
+ nontracked.cpp
+ wrapper.cpp
+ tst_qsharedpointer.cpp
+ LIBRARIES
+ Qt::CorePrivate
+)