summaryrefslogtreecommitdiffstats
path: root/tests/auto/dbus/qdbusconnection/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/dbus/qdbusconnection/CMakeLists.txt')
-rw-r--r--tests/auto/dbus/qdbusconnection/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/tests/auto/dbus/qdbusconnection/CMakeLists.txt b/tests/auto/dbus/qdbusconnection/CMakeLists.txt
index b50d92a64d..56ae21f291 100644
--- a/tests/auto/dbus/qdbusconnection/CMakeLists.txt
+++ b/tests/auto/dbus/qdbusconnection/CMakeLists.txt
@@ -1,12 +1,21 @@
-# Generated from qdbusconnection.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qdbusconnection Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qdbusconnection LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qdbusconnection
SOURCES
tst_qdbusconnection.cpp tst_qdbusconnection.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::DBus
+ TESTDATA
+ tst_qdbusconnection.conf
)