summaryrefslogtreecommitdiffstats
path: root/tests/auto/dbus/qdbusconnection_spyhook/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/dbus/qdbusconnection_spyhook/CMakeLists.txt')
-rw-r--r--tests/auto/dbus/qdbusconnection_spyhook/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/tests/auto/dbus/qdbusconnection_spyhook/CMakeLists.txt b/tests/auto/dbus/qdbusconnection_spyhook/CMakeLists.txt
index 6f197cd877..80417296a0 100644
--- a/tests/auto/dbus/qdbusconnection_spyhook/CMakeLists.txt
+++ b/tests/auto/dbus/qdbusconnection_spyhook/CMakeLists.txt
@@ -1,15 +1,22 @@
-# Generated from qdbusconnection_spyhook.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qdbusconnection_spyhook Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qdbusconnection_spyhook LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qdbusconnection_spyhook
SOURCES
../qdbusconnection/tst_qdbusconnection.h
tst_qdbusconnection_spyhook.cpp
DEFINES
tst_QDBusConnection=tst_QDBusConnection_SpyHook
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::DBus
)