summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/kernel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/kernel/CMakeLists.txt')
-rw-r--r--tests/auto/gui/kernel/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/auto/gui/kernel/CMakeLists.txt b/tests/auto/gui/kernel/CMakeLists.txt
index 33c8b35391..690a679833 100644
--- a/tests/auto/gui/kernel/CMakeLists.txt
+++ b/tests/auto/gui/kernel/CMakeLists.txt
@@ -43,7 +43,12 @@ if(TARGET Qt::Widgets)
add_subdirectory(qtouchevent)
endif()
if(QT_FEATURE_opengl)
- add_subdirectory(qopenglwindow)
+ # special case begin
+ # QTBUG-85364
+ if(NOT LINUX)
+ add_subdirectory(qopenglwindow)
+ endif()
+ # special case end
endif()
if(TARGET Qt::Network AND WIN32)
add_subdirectory(noqteventloop)