summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/painting/qcolortransform/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/painting/qcolortransform/CMakeLists.txt')
-rw-r--r--tests/auto/gui/painting/qcolortransform/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/auto/gui/painting/qcolortransform/CMakeLists.txt b/tests/auto/gui/painting/qcolortransform/CMakeLists.txt
new file mode 100644
index 0000000000..4aa4a8bc4a
--- /dev/null
+++ b/tests/auto/gui/painting/qcolortransform/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qcolortransform Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qcolortransform LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qcolortransform
+ SOURCES
+ tst_qcolortransform.cpp
+ LIBRARIES
+ Qt::Gui
+ Qt::GuiPrivate
+)