summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/text/qcssparser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/text/qcssparser/CMakeLists.txt')
-rw-r--r--tests/auto/gui/text/qcssparser/CMakeLists.txt53
1 files changed, 13 insertions, 40 deletions
diff --git a/tests/auto/gui/text/qcssparser/CMakeLists.txt b/tests/auto/gui/text/qcssparser/CMakeLists.txt
index 058a42d68c..e766ec5484 100644
--- a/tests/auto/gui/text/qcssparser/CMakeLists.txt
+++ b/tests/auto/gui/text/qcssparser/CMakeLists.txt
@@ -1,55 +1,28 @@
-# Generated from qcssparser.pro.
-
-if(NOT QT_FEATURE_private_tests)
- return()
-endif()
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qcssparser Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qcssparser LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
# Collect test data
-list(APPEND test_data "testdata")
+file(GLOB_RECURSE test_data
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ testdata/*
+)
qt_internal_add_test(tst_qcssparser
SOURCES
tst_qcssparser.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
Qt::GuiPrivate
Qt::Xml
TESTDATA ${test_data}
)
-
-#### Keys ignored in scope 1:.:.:qcssparser.pro:<TRUE>:
-# _REQUIREMENTS = "qtConfig(private_tests)"
-
-## Scopes:
-#####################################################################
-
-if(ANDROID)
- # Resources:
- set(testdata_resource_files
- "testdata/scanner/comments/input"
- "testdata/scanner/comments/output"
- "testdata/scanner/comments2/input"
- "testdata/scanner/comments2/output"
- "testdata/scanner/comments3/input"
- "testdata/scanner/comments3/output"
- "testdata/scanner/comments4/input"
- "testdata/scanner/comments4/output"
- "testdata/scanner/quotedstring/input"
- "testdata/scanner/quotedstring/output"
- "testdata/scanner/simple/input"
- "testdata/scanner/simple/output"
- "testdata/scanner/unicode/input"
- "testdata/scanner/unicode/output"
- )
-
- qt_internal_add_resource(tst_qcssparser "testdata"
- PREFIX
- "/"
- FILES
- ${testdata_resource_files}
- )
-endif()