summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/text/qfont/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/gui/text/qfont/CMakeLists.txt')
-rw-r--r--tests/auto/gui/text/qfont/CMakeLists.txt35
1 files changed, 18 insertions, 17 deletions
diff --git a/tests/auto/gui/text/qfont/CMakeLists.txt b/tests/auto/gui/text/qfont/CMakeLists.txt
index 6e0583bc30..88ae9959e4 100644
--- a/tests/auto/gui/text/qfont/CMakeLists.txt
+++ b/tests/auto/gui/text/qfont/CMakeLists.txt
@@ -1,18 +1,15 @@
-# Generated from qfont.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qfont Test:
#####################################################################
-qt_internal_add_test(tst_qfont
- SOURCES
- tst_qfont.cpp
- PUBLIC_LIBRARIES
- Qt::CorePrivate
- Qt::Gui
- Qt::GuiPrivate
- Qt::TestPrivate
-)
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qfont LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
# Resources:
set(testfont_resource_files
@@ -20,18 +17,22 @@ set(testfont_resource_files
"weirdfont.otf"
)
-qt_internal_add_resource(tst_qfont "testfont"
- PREFIX
- "/"
- FILES
- ${testfont_resource_files}
+qt_internal_add_test(tst_qfont
+ SOURCES
+ tst_qfont.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ Qt::TestPrivate
+ TESTDATA ${testfont_resource_files}
+ BUILTIN_TESTDATA
)
-
## Scopes:
#####################################################################
qt_internal_extend_target(tst_qfont CONDITION TARGET Qt::Widgets
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Widgets
)