summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/kernel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/network/kernel/CMakeLists.txt')
-rw-r--r--tests/auto/network/kernel/CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/tests/auto/network/kernel/CMakeLists.txt b/tests/auto/network/kernel/CMakeLists.txt
index c7b0d0dfeb..b42a9724b3 100644
--- a/tests/auto/network/kernel/CMakeLists.txt
+++ b/tests/auto/network/kernel/CMakeLists.txt
@@ -1,11 +1,15 @@
-# Generated from kernel.pro.
-if(NOT INTEGRITY)
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(QT_FEATURE_dnslookup AND (QT_FEATURE_libresolv OR WIN32))
add_subdirectory(qdnslookup)
add_subdirectory(qdnslookup_appless)
endif()
-add_subdirectory(qnetworkproxyfactory)
+if(QT_FEATURE_networkinterface)
+ add_subdirectory(qnetworkproxyfactory)
+ add_subdirectory(qnetworkinterface)
+endif()
add_subdirectory(qnetworkproxy)
-add_subdirectory(qnetworkinterface)
add_subdirectory(qnetworkdatagram)
add_subdirectory(qnetworkaddressentry)
add_subdirectory(qhostaddress)