summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/ssl/qpassworddigestor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/network/ssl/qpassworddigestor/CMakeLists.txt')
-rw-r--r--tests/auto/network/ssl/qpassworddigestor/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/tests/auto/network/ssl/qpassworddigestor/CMakeLists.txt b/tests/auto/network/ssl/qpassworddigestor/CMakeLists.txt
index 29eb26e377..96491eada9 100644
--- a/tests/auto/network/ssl/qpassworddigestor/CMakeLists.txt
+++ b/tests/auto/network/ssl/qpassworddigestor/CMakeLists.txt
@@ -1,12 +1,20 @@
-# Generated from qpassworddigestor.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qpassworddigestor Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qpassworddigestor LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qpassworddigestor
SOURCES
tst_qpassworddigestor.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Network
+ BUNDLE_ANDROID_OPENSSL_LIBS
)