summaryrefslogtreecommitdiffstats
path: root/tests/auto/opengl/qgl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/opengl/qgl/CMakeLists.txt')
-rw-r--r--tests/auto/opengl/qgl/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/tests/auto/opengl/qgl/CMakeLists.txt b/tests/auto/opengl/qgl/CMakeLists.txt
new file mode 100644
index 0000000000..8d640a6f52
--- /dev/null
+++ b/tests/auto/opengl/qgl/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Generated from qgl.pro.
+
+#####################################################################
+## tst_qgl Test:
+#####################################################################
+
+add_qt_test(tst_qgl
+ GUI
+ SOURCES
+ tst_qgl.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::OpenGLPrivate
+ Qt::WidgetsPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::OpenGL
+ Qt::Widgets
+)
+
+# Resources:
+set_source_files_properties("../../gui/image/qpixmap/images/designer.png"
+ PROPERTIES QT_RESOURCE_ALIAS "designer.png"
+)
+add_qt_resource(tst_qgl "qgl"
+ PREFIX
+ "/"
+ FILES
+ ../../gui/image/qpixmap/images/designer.png
+)
+
+
+#### Keys ignored in scope 1:.:.:qgl.pro:<TRUE>:
+# CONFIG = "testcase"