summaryrefslogtreecommitdiffstats
path: root/tests/auto/opengl/qglthreads/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/opengl/qglthreads/CMakeLists.txt')
-rw-r--r--tests/auto/opengl/qglthreads/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/auto/opengl/qglthreads/CMakeLists.txt b/tests/auto/opengl/qglthreads/CMakeLists.txt
new file mode 100644
index 0000000000..b9c47e7ead
--- /dev/null
+++ b/tests/auto/opengl/qglthreads/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from qglthreads.pro.
+
+if(NOT TARGET Qt::OpenGL)
+ return()
+endif()
+
+#####################################################################
+## tst_qglthreads Test:
+#####################################################################
+
+add_qt_test(tst_qglthreads
+ SOURCES
+ tst_qglthreads.cpp tst_qglthreads.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::OpenGL
+ Qt::Widgets
+)
+
+#### Keys ignored in scope 1:.:.:qglthreads.pro:<TRUE>:
+# _REQUIREMENTS = "qtHaveModule(opengl)"