summaryrefslogtreecommitdiffstats
path: root/tests/auto/other/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/other/CMakeLists.txt')
-rw-r--r--tests/auto/other/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/auto/other/CMakeLists.txt b/tests/auto/other/CMakeLists.txt
index 093a54aff8..6142d086b4 100644
--- a/tests/auto/other/CMakeLists.txt
+++ b/tests/auto/other/CMakeLists.txt
@@ -22,7 +22,8 @@ endif()
if(TARGET Qt::Network)
add_subdirectory(networkselftest)
endif()
-if(QT_FEATURE_accessibility AND TARGET Qt::Gui AND TARGET Qt::Widgets)
+# QTBUG-87674 # special case
+if(QT_FEATURE_accessibility AND TARGET Qt::Gui AND TARGET Qt::Widgets AND NOT ANDROID)
add_subdirectory(qaccessibility)
endif()
if(TARGET Qt::Gui)
@@ -30,7 +31,8 @@ if(TARGET Qt::Gui)
endif()
add_subdirectory(qobjectrace)
add_subdirectory(toolsupport)
-if(QT_FEATURE_process AND TARGET Qt::Gui)
+# QTBUG-87670 # special case
+if(QT_FEATURE_process AND TARGET Qt::Gui AND NOT ANDROID)
add_subdirectory(qprocess_and_guieventloop)
endif()
if(QT_FEATURE_accessibility_atspi_bridge AND TARGET Qt::Gui AND TARGET Qt::Widgets)