summaryrefslogtreecommitdiffstats
path: root/tests/auto/other/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/other/CMakeLists.txt')
-rw-r--r--tests/auto/other/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/auto/other/CMakeLists.txt b/tests/auto/other/CMakeLists.txt
index 808afeff35..6a9569332d 100644
--- a/tests/auto/other/CMakeLists.txt
+++ b/tests/auto/other/CMakeLists.txt
@@ -11,7 +11,7 @@ if(TARGET Qt::Widgets)
add_subdirectory(qsharedpointer_and_qwidget)
# add_subdirectory(windowsmobile) <- does not exist # special case
endif()
-if(TARGET Qt::Network AND TARGET Qt::Widgets AND NOT WINRT)
+if(TARGET Qt::Network AND TARGET Qt::Widgets)
add_subdirectory(lancelot)
add_subdirectory(qnetworkaccessmanager_and_qprogressdialog)
endif()
@@ -26,13 +26,13 @@ endif()
if(QT_FEATURE_process AND TARGET Qt::Gui)
add_subdirectory(qprocess_and_guieventloop)
endif()
-if(QT_FEATURE_accessibility AND TARGET Qt::Gui AND TARGET Qt::Widgets AND NOT WINRT)
+if(QT_FEATURE_accessibility AND TARGET Qt::Gui AND TARGET Qt::Widgets)
add_subdirectory(qaccessibility)
endif()
if(QT_FEATURE_accessibility_atspi_bridge AND TARGET Qt::Gui AND TARGET Qt::Widgets)
#add_subdirectory(qaccessibilitylinux) # special case # This test is broken
endif()
-if(TARGET Qt::Network AND NOT WINRT)
+if(TARGET Qt::Network)
add_subdirectory(networkselftest)
endif()
if(MACOS AND TARGET Qt::Gui)