summaryrefslogtreecommitdiffstats
path: root/tests/auto/other/macgui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/other/macgui/CMakeLists.txt')
-rw-r--r--tests/auto/other/macgui/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/auto/other/macgui/CMakeLists.txt b/tests/auto/other/macgui/CMakeLists.txt
new file mode 100644
index 0000000000..898abf16f4
--- /dev/null
+++ b/tests/auto/other/macgui/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Generated from macgui.pro.
+
+if(NOT APPLE)
+ return()
+endif()
+if(NOT TARGET Qt::Widgets) # special case
+ return()
+endif()
+
+#####################################################################
+## tst_macgui Test:
+#####################################################################
+
+add_qt_test(tst_macgui
+ SOURCES
+ guitest.cpp guitest.h
+ tst_macgui.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::WidgetsPrivate
+ PUBLIC_LIBRARIES
+ Qt::Widgets
+)
+
+#### Keys ignored in scope 1:.:.:macgui.pro:<TRUE>:
+# _REQUIREMENTS = "mac" "widgets"
+
+## Scopes:
+#####################################################################
+
+extend_target(tst_macgui CONDITION APPLE_OSX
+ PUBLIC_LIBRARIES
+ ${FWApplicationServices}
+)