summaryrefslogtreecommitdiffstats
path: root/tests/auto/other/macnativeevents/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/other/macnativeevents/CMakeLists.txt')
-rw-r--r--tests/auto/other/macnativeevents/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/auto/other/macnativeevents/CMakeLists.txt b/tests/auto/other/macnativeevents/CMakeLists.txt
new file mode 100644
index 0000000000..167e46055a
--- /dev/null
+++ b/tests/auto/other/macnativeevents/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Generated from macnativeevents.pro.
+
+if(NOT APPLE)
+ return()
+endif()
+
+#####################################################################
+## tst_macnativeevents Test:
+#####################################################################
+
+add_qt_test(tst_macnativeevents
+ SOURCES
+ expectedeventlist.cpp expectedeventlist.h
+ nativeeventlist.cpp nativeeventlist.h
+ qnativeevents.cpp qnativeevents.h
+ qnativeevents_mac.cpp
+ tst_macnativeevents.cpp
+ DEFINES
+ QT_DISABLE_DEPRECATED_BEFORE=0
+ PUBLIC_LIBRARIES
+ ${FWAppKit}
+ Qt::Gui
+ Qt::Widgets
+)
+
+#### Keys ignored in scope 1:.:.:macnativeevents.pro:<TRUE>:
+# _REQUIREMENTS = "mac"