summaryrefslogtreecommitdiffstats
path: root/tests/auto/other/qaccessibility/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/other/qaccessibility/CMakeLists.txt')
-rw-r--r--tests/auto/other/qaccessibility/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/tests/auto/other/qaccessibility/CMakeLists.txt b/tests/auto/other/qaccessibility/CMakeLists.txt
new file mode 100644
index 0000000000..f5f74bbafc
--- /dev/null
+++ b/tests/auto/other/qaccessibility/CMakeLists.txt
@@ -0,0 +1,51 @@
+# Generated from qaccessibility.pro.
+
+if(NOT QT_FEATURE_accessibility)
+ return()
+endif()
+
+# special case begin
+if (WIN32 AND NOT TARGET Qt::WindowsUIAutomationSupport)
+ return()
+endif()
+# special case end
+
+#####################################################################
+## tst_qaccessibility Test:
+#####################################################################
+
+add_qt_test(tst_qaccessibility
+ SOURCES
+ accessiblewidgets.h
+ tst_qaccessibility.cpp
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ Qt::TestPrivate
+ Qt::WidgetsPrivate
+)
+
+#### Keys ignored in scope 1:.:.:qaccessibility.pro:<TRUE>:
+# _REQUIREMENTS = "qtConfig(accessibility)"
+
+## Scopes:
+#####################################################################
+
+extend_target(tst_qaccessibility CONDITION UNIX AND NOT APPLE AND NOT HAIKU AND NOT integity
+ PUBLIC_LIBRARIES
+ m
+)
+
+extend_target(tst_qaccessibility CONDITION WIN32
+ PUBLIC_LIBRARIES
+ ole32
+ oleacc
+ oleaut32
+ uuid
+)
+
+extend_target(tst_qaccessibility CONDITION WIN32 AND NOT WINRT
+ PUBLIC_LIBRARIES
+ Qt::WindowsUIAutomationSupportPrivate
+)