summaryrefslogtreecommitdiffstats
path: root/tests/auto/other/qcomplextext/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/other/qcomplextext/CMakeLists.txt')
-rw-r--r--tests/auto/other/qcomplextext/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/tests/auto/other/qcomplextext/CMakeLists.txt b/tests/auto/other/qcomplextext/CMakeLists.txt
new file mode 100644
index 0000000000..883fabe01a
--- /dev/null
+++ b/tests/auto/other/qcomplextext/CMakeLists.txt
@@ -0,0 +1,42 @@
+# Generated from qcomplextext.pro.
+
+#####################################################################
+## tst_qcomplextext Test:
+#####################################################################
+
+# Collect test data
+list(APPEND test_data "data")
+
+add_qt_test(tst_qcomplextext
+ SOURCES
+ tst_qcomplextext.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ TESTDATA ${test_data}
+)
+
+## Scopes:
+#####################################################################
+
+if(ANDROID)
+ # Resources:
+ set(android_testdata_resource_files
+ "data/BidiCharacterTest.txt"
+ "data/BidiTest.txt"
+ )
+
+ add_qt_resource(tst_qcomplextext "android_testdata"
+ PREFIX
+ "/android_testdata"
+ FILES
+ ${android_testdata_resource_files}
+ )
+endif()
+
+extend_target(tst_qcomplextext CONDITION builtin_testdata
+ DEFINES
+ BUILTIN_TESTDATA
+)