summaryrefslogtreecommitdiffstats
path: root/tests/auto/sql/kernel/qsqlfield/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/sql/kernel/qsqlfield/CMakeLists.txt')
-rw-r--r--tests/auto/sql/kernel/qsqlfield/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/tests/auto/sql/kernel/qsqlfield/CMakeLists.txt b/tests/auto/sql/kernel/qsqlfield/CMakeLists.txt
index 7f8c97f584..2fef227201 100644
--- a/tests/auto/sql/kernel/qsqlfield/CMakeLists.txt
+++ b/tests/auto/sql/kernel/qsqlfield/CMakeLists.txt
@@ -1,12 +1,19 @@
-# Generated from qsqlfield.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qsqlfield Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qsqlfield LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qsqlfield
SOURCES
tst_qsqlfield.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Sql
)