summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/selftests/assert/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/testlib/selftests/assert/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/selftests/assert/CMakeLists.txt11
1 files changed, 4 insertions, 7 deletions
diff --git a/tests/auto/testlib/selftests/assert/CMakeLists.txt b/tests/auto/testlib/selftests/assert/CMakeLists.txt
index 6366feb4d3..947c056d02 100644
--- a/tests/auto/testlib/selftests/assert/CMakeLists.txt
+++ b/tests/auto/testlib/selftests/assert/CMakeLists.txt
@@ -1,15 +1,14 @@
# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR GPL-3.0-only WITH Qt-GPL-exception-1.0
-
-# Generated from assert.pro.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## assert Binary:
#####################################################################
qt_internal_add_executable(assert
- NO_INSTALL # special case
- OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} # special case
+ NO_INSTALL
+ EXCEPTIONS
+ OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
SOURCES
tst_assert.cpp
LIBRARIES
@@ -19,6 +18,4 @@ qt_internal_add_executable(assert
## Scopes:
#####################################################################
-# special case begin
qt_internal_apply_testlib_coverage_options(assert)
-# special case end