summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/selftests/cmptest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/testlib/selftests/cmptest/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/selftests/cmptest/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/auto/testlib/selftests/cmptest/CMakeLists.txt b/tests/auto/testlib/selftests/cmptest/CMakeLists.txt
new file mode 100644
index 0000000000..b7698c78f7
--- /dev/null
+++ b/tests/auto/testlib/selftests/cmptest/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Generated from cmptest.pro.
+
+#####################################################################
+## cmptest Binary:
+#####################################################################
+
+add_qt_executable(cmptest
+ NO_INSTALL # special case
+ OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} # special case
+ SOURCES
+ tst_cmptest.cpp
+ PUBLIC_LIBRARIES
+ Qt::Test
+)
+
+## Scopes:
+#####################################################################
+
+extend_target(cmptest CONDITION TARGET Qt::Gui
+ PUBLIC_LIBRARIES
+ Qt::Gui
+)