summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/selftests/findtestdata/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/testlib/selftests/findtestdata/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/selftests/findtestdata/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/auto/testlib/selftests/findtestdata/CMakeLists.txt b/tests/auto/testlib/selftests/findtestdata/CMakeLists.txt
new file mode 100644
index 0000000000..e565d611c2
--- /dev/null
+++ b/tests/auto/testlib/selftests/findtestdata/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Generated from findtestdata.pro.
+
+#####################################################################
+## findtestdata Binary:
+#####################################################################
+
+add_qt_executable(findtestdata
+ NO_INSTALL # special case
+ OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} # special case
+ SOURCES
+ findtestdata.cpp
+ PUBLIC_LIBRARIES
+ Qt::Test
+)
+
+# Resources:
+set(findtestdata_resource_files
+ "qt.conf"
+)
+
+add_qt_resource(findtestdata "findtestdata"
+ PREFIX
+ "/qt/etc/"
+ FILES
+ ${findtestdata_resource_files}
+)
+
+
+## Scopes:
+#####################################################################
+
+# special case begin
+qt_apply_testlib_coverage_options(findtestdata)
+# special case end