summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tools/CMakeLists.txt')
-rw-r--r--tests/auto/tools/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/auto/tools/CMakeLists.txt b/tests/auto/tools/CMakeLists.txt
new file mode 100644
index 0000000000..aa45587993
--- /dev/null
+++ b/tests/auto/tools/CMakeLists.txt
@@ -0,0 +1,17 @@
+# Generated from tools.pro.
+
+add_subdirectory(qmakelib)
+# special case begin
+if(NOT WIN32) # @todo: this is broken, see QTBUG-78449
+ add_subdirectory(qmake)
+endif()
+# special case end
+#add_subdirectory(moc)
+#add_subdirectory(rcc)
+if(TARGET Qt::Widgets)
+ add_subdirectory(uic)
+endif()
+if(TARGET Qt::DBus)
+ add_subdirectory(qdbuscpp2xml)
+ add_subdirectory(qdbusxml2cpp)
+endif()