summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/qmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tools/qmake/CMakeLists.txt')
-rw-r--r--tests/auto/tools/qmake/CMakeLists.txt34
1 files changed, 25 insertions, 9 deletions
diff --git a/tests/auto/tools/qmake/CMakeLists.txt b/tests/auto/tools/qmake/CMakeLists.txt
index a6aec5df5f..8fe0566baa 100644
--- a/tests/auto/tools/qmake/CMakeLists.txt
+++ b/tests/auto/tools/qmake/CMakeLists.txt
@@ -1,8 +1,11 @@
-# Generated from qmake.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-#####################################################################
-## tst_qmake Test:
-#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qmake LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
# Collect test data
file(GLOB_RECURSE test_data_glob
@@ -17,8 +20,21 @@ qt_internal_add_test(tst_qmake
TESTDATA ${test_data}
)
-## Scopes:
-#####################################################################
-
-#### Keys ignored in scope 2:.:.:qmake.pro:WIN32:
-# testcase.timeout = "900"
+set(dependencies
+ Qt::moc
+ Qt::qmake
+)
+if(TARGET Qt::Gui)
+ list(APPEND dependencies Qt::Gui)
+endif()
+if(TARGET Qt::Widgets)
+ list(APPEND dependencies Qt::Widgets)
+endif()
+if(TARGET Qt::rcc)
+ list(APPEND dependencies Qt::rcc)
+endif()
+if(TARGET Qt::uic)
+ list(APPEND dependencies Qt::uic)
+endif()
+# Add dependencies that are implicitly used inside the test
+add_dependencies(tst_qmake ${dependencies})