summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/qmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tools/qmake/CMakeLists.txt')
-rw-r--r--tests/auto/tools/qmake/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/auto/tools/qmake/CMakeLists.txt b/tests/auto/tools/qmake/CMakeLists.txt
new file mode 100644
index 0000000000..23b81fe9f5
--- /dev/null
+++ b/tests/auto/tools/qmake/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Generated from qmake.pro.
+
+#####################################################################
+## tst_qmake Test:
+#####################################################################
+
+# Collect test data
+
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ "testdata/*")
+list(APPEND test_data ${test_data_glob})
+
+add_qt_test(tst_qmake
+ GUI
+ SOURCES
+ testcompiler.cpp testcompiler.h
+ tst_qmake.cpp
+ TESTDATA ${test_data}
+)
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qmake.pro:WIN32:
+# testcase.timeout = "900"
+
+extend_target(tst_qmake CONDITION (CMAKE_CROSSCOMPILING) # special case
+ DEFINES
+ QMAKE_CROSS_COMPILED
+)