summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/qmakelib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tools/qmakelib/CMakeLists.txt')
-rw-r--r--tests/auto/tools/qmakelib/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/tests/auto/tools/qmakelib/CMakeLists.txt b/tests/auto/tools/qmakelib/CMakeLists.txt
new file mode 100644
index 0000000000..4a07a2b477
--- /dev/null
+++ b/tests/auto/tools/qmakelib/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Generated from qmakelib.pro.
+
+#####################################################################
+## tst_qmakelib Test:
+#####################################################################
+
+add_qt_test(tst_qmakelib
+ GUI
+ SOURCES
+ ../../../../qmake/library/ioutils.cpp
+ ../../../../qmake/library/proitems.cpp
+ ../../../../qmake/library/qmakebuiltins.cpp
+ ../../../../qmake/library/qmakeevaluator.cpp
+ ../../../../qmake/library/qmakeglobals.cpp
+ ../../../../qmake/library/qmakeparser.cpp
+ ../../../../qmake/library/qmakevfs.cpp
+ ../../../../qmake/library/registry.cpp
+ evaltest.cpp
+ parsertest.cpp
+ tst_qmakelib.cpp tst_qmakelib.h
+ DEFINES
+ PROEVALUATOR_FULL
+ PROEVALUATOR_SETENV
+ PROPARSER_DEBUG
+ INCLUDE_DIRECTORIES
+ ../../../../qmake/library
+)
+
+## Scopes:
+#####################################################################
+
+extend_target(tst_qmakelib CONDITION WIN32
+ PUBLIC_LIBRARIES
+ advapi32
+)