summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/rcc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tools/rcc/CMakeLists.txt')
-rw-r--r--tests/auto/tools/rcc/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/tests/auto/tools/rcc/CMakeLists.txt b/tests/auto/tools/rcc/CMakeLists.txt
index abcf3a1f60..96863c49bd 100644
--- a/tests/auto/tools/rcc/CMakeLists.txt
+++ b/tests/auto/tools/rcc/CMakeLists.txt
@@ -1,9 +1,16 @@
-# Generated from rcc.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_rcc Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_rcc LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_rcc
SOURCES
tst_rcc.cpp
@@ -63,3 +70,8 @@ qt_internal_add_resource(tst_rcc "size-1"
FILES
${size-1_resource_files}
)
+
+# Add dependencies that are implicitly used inside the test
+add_dependencies(tst_rcc
+ Qt::rcc
+)