summaryrefslogtreecommitdiffstats
path: root/tests/auto/widgets/dialogs/qfontdialog/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/widgets/dialogs/qfontdialog/CMakeLists.txt')
-rw-r--r--tests/auto/widgets/dialogs/qfontdialog/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/tests/auto/widgets/dialogs/qfontdialog/CMakeLists.txt b/tests/auto/widgets/dialogs/qfontdialog/CMakeLists.txt
new file mode 100644
index 0000000000..345822ac79
--- /dev/null
+++ b/tests/auto/widgets/dialogs/qfontdialog/CMakeLists.txt
@@ -0,0 +1,40 @@
+# Generated from qfontdialog.pro.
+
+#####################################################################
+## tst_qfontdialog Test:
+#####################################################################
+
+add_qt_test(tst_qfontdialog
+ SOURCES
+ tst_qfontdialog.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::WidgetsPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Widgets
+)
+
+# Resources:
+set_source_files_properties("../../../shared/resources/test.ttf"
+ PROPERTIES QT_RESOURCE_ALIAS "test.ttf"
+)
+set_source_files_properties("../../../shared/resources/testfont.ttf"
+ PROPERTIES QT_RESOURCE_ALIAS "testfont.ttf"
+)
+set(testfonts_resource_files
+ "../../../shared/resources/test.ttf"
+ "../../../shared/resources/testfont.ttf"
+)
+
+add_qt_resource(tst_qfontdialog "testfonts"
+ PREFIX
+ "/"
+ FILES
+ ${testfonts_resource_files}
+)
+
+
+## Scopes:
+#####################################################################