summaryrefslogtreecommitdiffstats
path: root/tests/auto/widgets/dialogs/qfontdialog/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/widgets/dialogs/qfontdialog/CMakeLists.txt')
-rw-r--r--tests/auto/widgets/dialogs/qfontdialog/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/auto/widgets/dialogs/qfontdialog/CMakeLists.txt b/tests/auto/widgets/dialogs/qfontdialog/CMakeLists.txt
new file mode 100644
index 0000000000..58cda26f0a
--- /dev/null
+++ b/tests/auto/widgets/dialogs/qfontdialog/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Generated from qfontdialog.pro.
+
+#####################################################################
+## tst_qfontdialog Test:
+#####################################################################
+
+add_qt_test(tst_qfontdialog
+ SOURCES
+ tst_qfontdialog.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::WidgetsPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Widgets
+)
+
+# Resources:
+set_source_files_properties("../../../shared/resources/test.ttf"
+ PROPERTIES alias "test.ttf")
+set_source_files_properties("../../../shared/resources/testfont.ttf"
+ PROPERTIES alias "testfont.ttf")
+add_qt_resource(tst_qfontdialog "testfonts" PREFIX "/" FILES
+ ../../../shared/resources/test.ttf
+ ../../../shared/resources/testfont.ttf)
+
+
+#### Keys ignored in scope 1:.:.:qfontdialog.pro:<TRUE>:
+# CONFIG = "testcase"
+
+## Scopes:
+#####################################################################